Azure AU Region - Maintenance from 2026-08-16 18:41 EEST to 2026-08-16 19:13 EEST

Scheduled maintenance BSS Storefront AU region AU region
2026-08-16 18:41 EEST · 32 minutes

Updates

Resolved

Azure AU Region Maintenance completed

August 16, 2026 · 19:13 EEST
Investigating

Azure AU Region Maintenance kicked off

August 16, 2026 · 18:41 EEST

← Back