Azure AU Region - Maintenance from 2026-08-02 21:09 EEST to 2026-08-02 21:46 EEST

Scheduled maintenance BSS Storefront AU region AU region
2026-08-02 21:09 EEST · 37 minutes

Updates

Resolved

Azure AU Region Maintenance completed

August 2, 2026 · 21:46 EEST
Investigating

Azure AU Region Maintenance kicked off

August 2, 2026 · 21:09 EEST

← Back