Azure AU Region - Maintenance from 2026-07-27 15:46 EEST to 2026-07-27 16:37 EEST

Scheduled maintenance BSS Storefront AU region AU region
2026-07-27 15:46 EEST · 51 minutes

Updates

Resolved

Azure AU Region Maintenance completed

July 27, 2026 · 16:37 EEST
Investigating

Azure AU Region Maintenance kicked off

July 27, 2026 · 15:46 EEST

← Back