Azure US Region - Maintenance from 2026-07-19 00:40 EEST to 2026-07-19 01:30 EEST

Scheduled maintenance BSS US region Storefront US region
2026-07-19 00:40 EEST · 49 minutes

Updates

Resolved

Azure US Region Maintenance completed

July 19, 2026 · 01:30 EEST
Investigating

Azure US Region Maintenance kicked off

July 19, 2026 · 00:40 EEST

← Back