Azure AU Region - Maintenance from 2026-07-19 00:05 EEST to 2026-07-19 00:37 EEST

Scheduled maintenance BSS Storefront AU region AU region
2026-07-19 00:05 EEST · 32 minutes

Updates

Resolved

Azure AU Region Maintenance completed

July 19, 2026 · 00:37 EEST
Investigating

Azure AU Region Maintenance kicked off

July 19, 2026 · 00:05 EEST

← Back