Azure US Region - Maintenance from 2026-07-14 14:56 EEST to 2026-07-14 15:00 EEST

Scheduled maintenance BSS US region Storefront US region
2026-07-14 14:56 EEST · 4 minutes

Updates

Resolved

Azure US Region Maintenance completed

July 14, 2026 · 15:00 EEST
Investigating

Azure US Region Maintenance kicked off

July 14, 2026 · 14:56 EEST

← Back