Azure AU Region - Maintenance from 2026-07-14 14:13 EEST to 2026-07-14 14:21 EEST

Scheduled maintenance BSS Storefront AU region AU region
2026-07-14 14:13 EEST · 8 minutes, 1 second

Updates

Resolved

Azure AU Region Maintenance completed

July 14, 2026 · 14:21 EEST
Investigating

Azure AU Region Maintenance kicked off

July 14, 2026 · 14:13 EEST

← Back