Azure AU Region - Maintenance from 2026-07-08 12:26 EEST to 2026-07-08 12:31 EEST

Scheduled maintenance BSS Storefront AU region AU region
2026-07-08 12:26 EEST · 4 minutes

Updates

Resolved

Azure AU Region Maintenance completed

July 8, 2026 · 12:31 EEST
Investigating

Azure AU Region Maintenance kicked off

July 8, 2026 · 12:26 EEST

← Back