Azure AU Region - Maintenance from 2026-06-28 21:16 EEST to 2026-06-28 21:42 EEST

Scheduled maintenance BSS Storefront AU region AU region
2026-06-28 21:16 EEST · 26 minutes

Updates

Resolved

Azure AU Region Maintenance completed

June 28, 2026 · 21:42 EEST
Investigating

Azure AU Region Maintenance kicked off

June 28, 2026 · 21:16 EEST

← Back