Azure US Region - Maintenance from 2026-05-23 16:03 EEST to 2026-05-23 17:11 EEST

Scheduled maintenance BSS US region Storefront US region
2026-05-23 16:03 EEST · 1 hour, 7 minutes

Updates

Resolved

Azure US Region Maintenance completed

May 23, 2026 · 17:11 EEST
Investigating

Azure US Region Maintenance kicked off

May 23, 2026 · 16:03 EEST

← Back