Azure US Region - Maintenance from 2026-05-08 16:42 EEST to 2026-05-08 18:36 EEST

Scheduled maintenance BSS US region Storefront US region
2026-05-08 16:42 EEST · 1 hour, 53 minutes

Updates

Resolved

Azure US Region Maintenance completed

May 8, 2026 · 18:36 EEST
Investigating

Azure US Region Maintenance kicked off

May 8, 2026 · 16:42 EEST

← Back