Azure US Region - Maintenance from 2026-04-16 16:13 EEST to 2026-04-16 17:41 EEST

Scheduled maintenance BSS US region Storefront US region
2026-04-16 16:13 EEST · 1 hour, 28 minutes

Updates

Resolved

Azure US Region Maintenance completed

April 16, 2026 · 17:41 EEST
Investigating

Azure US Region Maintenance kicked off

April 16, 2026 · 16:13 EEST

← Back