Azure US Region - Maintenance from 2026-03-21 16:22 EET to 2026-03-21 17:12 EET

Scheduled maintenance BSS US region Storefront US region
2026-03-21 16:22 EET · 49 minutes

Updates

Resolved

Azure US Region Maintenance completed

March 21, 2026 · 17:12 EET
Investigating

Azure US Region Maintenance kicked off

March 21, 2026 · 16:22 EET

← Back