Azure US Region - Maintenance from 2026-03-17 12:13 EET to 2026-03-17 12:22 EET

Scheduled maintenance BSS US region Storefront US region
2026-03-17 12:13 EET · 8 minutes

Updates

Resolved

Azure US Region Maintenance completed

March 17, 2026 · 12:22 EET
Investigating

Azure US Region Maintenance kicked off

March 17, 2026 · 12:13 EET

← Back