Azure US Region - Maintenance from 2026-03-14 15:53 EET to 2026-03-14 17:02 EET

Scheduled maintenance BSS US region Storefront US region
2026-03-14 15:53 EET · 1 hour, 8 minutes

Updates

Resolved

Azure US Region Maintenance completed

March 14, 2026 · 17:02 EET
Investigating

Azure US Region Maintenance kicked off

March 14, 2026 · 15:53 EET

← Back