Azure US Region - Maintenance from 2026-02-26 08:51 EET to 2026-02-26 09:39 EET

Scheduled maintenance BSS US region Storefront US region
2026-02-26 08:51 EET · 48 minutes

Updates

Resolved

Azure US Region Maintenance completed

February 26, 2026 · 09:39 EET
Investigating

Azure US Region Maintenance kicked off

February 26, 2026 · 08:51 EET

← Back