Azure US Region - Maintenance from 2026-02-22 16:01 EET to 2026-02-23 03:54 EET

Scheduled maintenance BSS US region Storefront US region
2026-02-22 16:01 EET · 11 hours, 52 minutes

Updates

Resolved

Azure US Region Maintenance completed

February 23, 2026 · 03:54 EET
Investigating

Azure US Region Maintenance kicked off

February 22, 2026 · 16:01 EET

← Back