Azure EU Region - Maintenance from 2026-02-03 02:46 EET to 2026-02-03 03:27 EET

Scheduled maintenance BSS EU region Storefront EU region
2026-02-03 02:46 EET · 40 minutes

Updates

Resolved

Azure EU Region Maintenance completed

February 3, 2026 · 03:27 EET
Investigating

Azure EU Region Maintenance kicked off

February 3, 2026 · 02:46 EET

← Back