Azure US Region - Maintenance from 2026-01-15 08:41 EET to 2026-01-15 12:31 EET

Scheduled maintenance BSS EU region US region Storefront US region
2026-01-15 08:41 EET · 3 hours, 49 minutes

Updates

Resolved

Scheduled maintenance completed

January 15, 2026 · 12:31 EET
Investigating

Azure US Region Maintenance kicked off

January 15, 2026 · 08:41 EET

← Back