BSS Sites - Azure EU region - Service Disruption

Major incident BSS Azure EU region
2025-12-23 14:40 EET · 37 minutes

Updates

Resolved

test 453453453

December 23, 2025 · 15:18 EET
Investigating

We are currently investigating an issue which impacts cloud platform’s BSS application availability.

December 23, 2025 · 14:40 EET

← Back