BSS Sites - Azure EU region - Service Disruption (bss)

Major incident BSS Azure EU region
2025-12-22 12:41 EET · 59 minutes

Updates

Resolved

test

December 22, 2025 · 13:40 EET
Investigating

We are currently investigating an issue which impacts cloud platform’s BSS application availability.

December 22, 2025 · 12:41 EET

← Back